D-Link DSL2640R e DSL2740R come Access Point

D-Link DSL2640R e DSL2740R come Access Point

Originariamente pubblicato su FacileWiFi il 27/02/2014

http://www.facilewifi.eu/viewtopic.php?f=7&t=3817

Ho comperato il D-Link DSL2640R modem/router per una bassa cifra su ebay, in uno scatolo che comprendeva anche una pennetta WiFi, la DWA-110. Il tutto chiamato kit DKT-710. Solo dopo mi sono accorto che la versione R del DSL2640 è completamente differente dalle precedenti versioni B,U e altre belle letterine. Queste hanno un Broadcom e il supporto ad OpenWrt, questo invece ha un Trendchip, 2 Mega di flash (!) e niente openwrt. Anzi, niente e basta. Da targhetta è un revisione B1.

La maggior parte delle informazioni in italiano le trovate nel forum D-Link

http://www.dlink-forum.info/showthread.php?tid=95

curiosamente non ci sono pagine in altre lingue con informazioni paragonabili a quanto si trova nel forum D-Link in italiano.

Questa è la pagina ufficiale di D-Link

http://www.dlink.com/uk/en/support/product/dsl-2640r-wireless-g-adsl2plus-modem-router?revision=deu_revb1

ma il firmware che trovate è una versione inferiore rispetto a quella che si trova sul forum. Si tratta di un prodotto andato fuori produzione.

Nonostante quanto affermato nel forum, il firmware versione VT_1.17 ha aperto l’accesso Telnet e anche uno FTP.

In FTP trovate solo 2 file rom-0 (16384 byte) e ras (1441118 byte), quest’ultimo in sola scrittura. rom-0 è il file che contiene la configurazione che potete scaricare dall’interfaccia web.

In telnet purtroppo non accedete ad una busybox ma ad una sorta di shell proprietaria simile al Discus dell’AGPF e di altri modem/router Pirelli.

Mi ero rassegnato a destinare questo router per esperimenti ad alto rischio quando mi è venuta l’idea di provare a farlo funzionare come Access Point, cioè collegarlo al router principale via cavo e permettere il collegamento via WiFi. Ha funzionato!

Per far questo ho semplicemente configurato la sezione WiFi come se si trattasse di un modem router e ho assegnato un IP fisso nella sezione netwrork. Ho disabilitato il DHCP.

Quest’ultima assegnazione probabilmente è ininfluente per il funzionamento in quanto sebbene con IP della LAN abbia messo 192.168.1.7, quando si collega all’altro router, il Vela

che ha IP 192.168.2.9, il PC prende l’IP dal Vela e la navigazione funziona. Il D-Link però è inaccessibile a meno che non mi ci collego via LAN. Forse, se come IP fisso usassi 192.168.2.7 risolverei anche questo ma per me non è un problema per cui lo lascio così com’è.

Edit: da esperimenti fatti effettivamente l’IP LAN di questo apparato è ininfluente. Se volete avere l’accesso all’interfaccia web dovete usare un IP fisso della stessa sottorete del router cui è collegato.

E’ perfettamente plausibile che tale comportamento sia comune ad altri apparati.

Non contento dell’errore fatto la prima volta ho preso un D-Link2740R che sembra il successore di questo vista la quasi identica configurazione hardware. L’ho preso per meno di 5 euro pensando che al limite ne avrei sfruttato l’alimentatore. Ha due antenne invece che una. La configurazione è stata fatta nella stessa maniera del 2640 e ha funzionato perfettamente.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: